Skip Ribbon Commands
Skip to main content

Skip Navigation LinksHow to setup a larger review site

​NOTE: If you want to setup a small review/workshop site go here.
For large reviews in a series, it is helpful to make the new review site look like the most recent past review site.
  • Communicate the following to OPSS when it is known
    • URL of our review site
    • coordinate agenda changes with them and LBNF
    • coordinate Final report and closeout presentation on review site with OPSS and LBNF
  • Go to https://web.fnal.gov/project/LBNF/ReviewsAndAssessments/SitePages/Reviews,%20Workshops,%20Meetings.aspx and login with your services account
  • Go to Site contents
  • click the ‘new subsite’ button beneath the list of apps (need Full Control access to be able to do this) Be consistent with past reviews as appropriate.
    • Title - the title of the review
    • URL Name - copy the title into here.  you must replace any back or forward slashes or other special characters with an underscore or dash.
    • Keep the Team site template selected
    • Keep the same permissions as the parent site
    • Do not use the top link bar from the parent site
    • Click the ‘Create’ button
  • Remove the ‘Get started with your site’ by clicking ‘REMOVE THIS'
  • Edit the page
  • Remove the ‘Site Feed’ web part
  • Remove the 'Documents’ web part
  • Click the 'Text Layout' button the on ribbon and select the format for the page that you want. ('Two columns with header' is the most used, but you can do what you want,)
  • Save the page
  • Setup the left hand navigation (you can do this from the main page if the 'EDIT LINKS' button is there, you need permissions to do this) Click EDIT LINKS to do the following

    • Remove all links except the Home link
    • Click the ‘Home’ link
    • Change ‘Home’ to ‘Review Home'
    • Click Enter/return
    • if this review is at Fermi, add the following link to the Current (left hand side) Navigation
    • Click 'link'
    • Enter Text to display - Request Assistance
    • Enter URL - mailto:lbnf-communication@fnal.gov?subject=Request Assistance for <enter review name here>
      • change the <enter review name here> to something that uniquely identifies this review.
    • Click ‘OK'
    • Request Assistance should be at the same level of indent as General Information. Make it the last link in the left hand navigation list of links.
    • Click 'link'
    • Enter Text to display - Review Information
    • There is no URL, this is a heading.
    • Click 'OK'
    • This link should be just below the 'Review Home' link. Then add the following links under this heading
      • Add a link to the OPSS review site (which you can get from OPSS) titled 'OPSS Review Home'
      • Add a link to http://lbnf.fnal.gov titled 'LBNF Information
      • Add a link to http://www.dunescience.org titled 'DUNE Information'
    • click ‘Save'
  • Insert the list of reviewers/attendees on the page per style of review (the location/formatting of this should be adjusted to meet the needs of the review, look at the most recent last review of this type)
    • Edit the review home page
    • put your cursor in the bottom right boxed area on the page. (or elsewhere if you have selected a different text layout)
    • Type the title for the list of people you will add (for example Reviewers or Attendees)
    • Make this a Heading 2 Style type
    • Hit carriage return
    • Select Insert from the ribbon
    • Select Table from the ribbon
    • Select one column if all you have is a name. Two columns if you have other information to enter for each person
    • Select as many row as you can or as many people as you have.  you will add rows later
    • Select the Design tab above the ribbon
    • Unselect the ‘Footer Row' if it is checked
    • Put your cursor in the first row, type the first name 
    • Continue in a new row for each person
    • You can adjust the width of the columns under the ‘Table Layout’ tab in the ribbon
    • To add a row put your cursor in the last row, if needed
    • Select ‘Insert Below’ from the ribbon as many times as you need
    • Save the page
  • Insert the general review information
    • Edit the review home page
    • put your cursor in the top boxed area that spans the whole page
    • Enter the dates of the review
    • Make this a Heading 1 Style
    • on the next line, enter the location of the review
    • Make this a Heading 2 style
    • Add the text 'Review Information' or 'Links' as a Heading 2 in the left hand side column.
    • Add links to the Charge (if known) and other introductory review documentation as a bulleted list under this heading, for reviewers to find.
    • For DOE level reviews, the Review Team Contact List and Project Contact List can be found on the OPSS REview Home site.
    • Add text for the Final Review Report in the same place.  Change this to an actual link once the report exists.
    • Save the Page
  • Determine headings/​str​ucture for agenda and document categories (from PM)​
  • Create the Agenda
    • Select the Gear in the upper right hand corner
    • Select Add an App
    • Scroll to the bottom of the page
    • Click the right facing arrow next to the 1-16 to go to the next page of Apps
    • Do this until you get to the page with the app ‘LBNF Large Meeting Agenda'.
    • Select that App
    • Name - Agenda
    • Click the Create button
    • Click the Agenda App now appearing in the Site Contents page
    • Select the List tab in the ribbon
    • Select List Settings in the ribbon
    • Select ‘Item’ under ‘Content Types'
    • Select ‘Title'
    • Select ‘Hidden’ under ‘Column Settings'
    • Select ‘Ok'
    • Click the 'Settings' heading (looks like the title) at the top of this page to go back to the general settings page
    • Change the default day for the Agenda items to be the first day of the agenda by doing the following -
      • Scroll down to where the columns are listed
      • Click on the "Start Time' column
      • Under 'Default Value' enter the day of the review you want to be the default
      • Select 'Ok'
  • Add the agenda page (the web parts for what will become each agenda tab need to be listed on the page in the order you want them to appear.)
    • Select the Gear in the upper right hand corner
    • Select Add a Page
      • New page name - Agenda
    • Click Create
    • If the meeting will be accessible with zoom cut and paste the following zoom information onto the top of the page. this info may change from review to review. the links with the access codes wll need to change as they become known.

Remote Meeting Access using Zoom

  Audio Dial-In - 1-646-558-8656    or    1-669-900-6833

  International Numbers can be found here

  Meeting ID: see agenda items (Access Code)

  Main Session Web Access: https://fnal.zoom.us/j/nnnnnnnnn

   Beamline Web Access: https://fnal.zoom.us/j/nnnnnnnnn

  Conventional Facilities Web Access:

  Cryogenic Infrastructure Web Access: https://fnal.zoom.us/j/nnnnnnnnn

  Detectors Web Access: https://fnal.zoom.us/j/nnnnnnnnn

  Management Web Access: https://fnal.zoom.us/j/nnnnnnnnn


    • Replace the access code above (nnnnnnnnn) with the access code(s) to be used for the review
    • Add an <HR> line (or other formatting) below the zoom info to separate it from the actual agenda if you want.
    • Configure the Agenda page to have all the web parts needed on it. (you want to save frequently)
      • Place your cursor on the page below the line which is below the zoom information
      • Select the ‘Insert’ tab on the top of the ribbon
      • Select 'Web Part'
      • Select 'Custom'->'Fermilab.SP13.Sandbox.Tabbed - TabbedWebPart'
      • Click the 'Add' button
      • Edit this web part
      • Under 'Title' put 'Full Agenda'
      • Under 'Miscellaneaous' in the WebParts box put 'Content Editor; Fermilab Hiding Group Headers' (without the quotes)
      • Click the 'Ok'
      • HERE: Place your cursor at the bottom of the page below the TabbedWebPart on the page


      • Select the ‘Insert’ tab on the top of the ribbon
      • Select ‘App Part'
      • Select ‘Agenda'
      • Click the 'Add' button
      • Do the last several steps (starting with HERE just above) for each agenda view that you want to include (do not configure the views yet)
      • Save the page and start editing again
      • CONFIGURE VIEWS: Select the leftmost tab
      • Edit the Agenda web part (hover mouse over agenda underneath the blue bar which is under the full agenda title, click the down arrow on the right hand side, select 'Edit Web Part')
      • Select ‘Main’ or 'Plenary' in the ‘Selected View’ section
      • Click 'Ok' to the popup.
      • Set the 'Title' (under Appearance) to be 'Main' or 'Plenary'
      • Click OK
      • Do the last several steps (starting with CONFIGURE VIEWS just above) for each agenda view that you included (substitute the desired agenda view name for 'Main' or 'Plenary' in both the view selection and the title). Add the views in alphabetical order, keeping the 'Main/Plenary' one first.
      • Save the page and start editing again
      • NICE FORMATTING: Add two web parts to this page to format the agenda nicely, do the following -
        • Put your cursor at the bottom of the page
        • Click the 'Insert' tab at the top of the ribbon
        • Select 'Web Part'
        • Select 'Custom' from Categories section
        • Select 'Fermilab Hiding Group Headers' from Parts section
        • Click 'Add' button
        • Edit the 'Fermilab Hiding Group Headers' web part (hover mouse over the web part, click the down arrow on the right hand side, select 'Edit Web Part')
        • Under the Appearance section set the 'Chrome Type' to be 'None'
        • Click OK
        • Put your cursor at the bottom of the page
        • Click the 'Insert' tab at the top of the ribbon
        • Select 'Web Part'
        • Select 'Media and Content' from Categories section
        • Select 'Content Editor' from Parts section
        • Click 'Add' button
        • Edit the 'Content Editor' web part (hover mouse over the web part, click the down arrow on the right hand side, select 'Edit Web Part')
        • Paste the following link into the 'Content Link' section near the top
        • Under the Appearance section set the 'Chrome Type' to be 'None'
        • Click OK
      • Save the Page
    • Copy the URL of this Agenda page
    • click 'Edit Links'
    • Click 'link'
    • Set Text to  - Agenda
    • URL - the copied URL of the agenda page
    • Click Ok
    • Click the Agenda link that was just created
    • Place the Agenda link just below ‘OPSS Review Home’ and at the same indentation level
    • Remove the ‘Recent’ items and header as you removed the items earlier.
    • Add a link just below the Agenda link titled 'One Page Agenda'
    • Click 'Save'
    • Create a new page titled 'One Page Agenda'
    • Add to it the Agenda app part and edit this web part to show the 'Main' or 'Plenary' view. (set title to Main or Plenary also)
    • Click OK
    • Below this add a Text line that is 'Breakout Sessions' in a large enough font to be easily viewable when the page is scanned.
    • Below this add the Agenda app part as many times as there are different views (in alphabetical order) you want to show (i.e. Beamline, Cryogenics, Detectors...)
    • Set the view and the title for each web part
    • Save the page, and start editing again
    • At the bottom of this add the same two web parts (starting at NICE FORMATTING above) that were added above to the Agenda page to make the page look nice. (Make sure to edit them as listed above too)
    • Put your cursor at the bottom of the page
    • Add a Script Editor Web part(in Media and Content)
    • Edit the web part
    • go back to the web part on the page and select Edit Snippet.
    • Paste the following in
    • <style type="text/css">
        .ms-webpart-titleText.ms-webpart-titleText, .ms-webpart-titleText > a {
         background-color: darkblue;
         font-size: 16px;   
         font-weight: bold;
         color: white;
         padding: 5px 5px;}
      </style>
    • Click OK
    • Save the page.
    • Copy the URL for this page and edit the left hand side navigation to point the title 'One Page Agenda' to this new page.
    • Make sure each of the views is showing the same columns.  If not, edit the Agenda list to change the view that is wrong. You will need to reselect the view that was changed on bothe the Agenda page and the One Page Agenda page

  • Add any documentation to the review site
    • Remove the 'Recent' Heading and anyting indented with it from the Current links on the left hand side.
    • Add a heading to the left hand side navigation that is called 'Review Documentation'. place it after 'Review Information' section and at the same indentation level.
    • This works differently for every review instance. Most documentation is in DocDB. You should save a document library from a the most recent former similar sized review (as a template - name it apprpriately) to then use as a template for this library. Save with or without content as you would like. Pick the new template as the app to add to the review site. Usually it is called 'Master Document List'
    • Once the library exists, create a page for each view you want to show (Beamline, Cryogenics, Detectors,...) and add a link to each new page under the Review Documentation heading.
    • Also add links to the following under the Review Documentation heading -
      •  A link to the Master Document List view titled 'DOE Project Approvals' with link title the same
      • A link to the Master Document list view titled 'Reviews' with link title the same (make sure this list is up to date)
    • The following links may also need to be added to the Review Documentation depending on the review -
      • a link to a page with 'Interfaces (Far Site)' on it
      • a link to a page with 'Interfaces (Near Site)' on it
      • a link to a page with the 'Requirements Traceback' on it
  • Add the 'Answers to Reviewer Questions' information
    • Click 'Review Home'
    • Add the app from a template, 'LBNF Answers to Review Questions' to the site. title it 'Answers to Reviewer Questions'
    • Click on the 'Answers to Reviewer Questions' on the site contents page
    • Copy the link from the URL bar
    • Add a link on the left hand side navigation that is called 'Answers to Reviewer Questions' and points to this list.
    • This link should come just before the 'General Information' heading and be at the same indentation level.
  • Add the review/workshop to the list of reviews
    • Click on Review Home in the left hand navigation to get to the main page of the review
    • Copy the URL
    • Go to the main review listing at - https://web.fnal.gov/project/LBNF/ReviewsAndAssessments/SitePages/Reviews,%20Workshops,%20Meetings.aspx
    • Select ‘new item' (it does not matter which blue tab you are seeing)
    • Item - name of the review/workshop. 
    • Make Item a link to the review site just created.
      • Select the title text in the Item box
      • Select Insert from the ribbon
      • Select Link
      • Select From Adress
        • URL is the copied URL of the review site
    • Date - Dates of the review (ex June 3-5, 2015)
    • Start Date - first day of the review
    • End Date - last day of the review (there is guidance on this below the entry box)
    • Category - pick the most appropriate entry
    • Review Type - same here
    • Location - fill in location, try to make it the same as the other locations already used
    • Click Save (this will automatically add it to the LBNF Calendar)


Other things to do:

  • Reserve docdb numbers for talks. 
    • Get schedule from PM with talk titles and speakers. Start each docdb title with "(Review title) presentation:"
    • Set view and modify to lbnfpm, dunepm and cam (unless specified otherwise)
    • Select the review topic from under reviews.
Once the presentation type content editor webpart is in and you see the tab in the Agenda, click the arrow within that webpart (see figure at left) and configure it for the view (shown for ES&H):



Sample Agenda web page in edit mode:

 

Sample left hand side Navigation link appearance -




How to Create the Thumbdrives

  • Do several weeks in advance of the review:
    • Contact OPSS to learn if you need to create the thumbdrives for the review and how many should be created.  (The rest of these instuctions assume the answer was yes).
    • Check the number of thumbdrives to create with Elaine to make sure she does not want additional ones created too. Add one to the number of thumbdrives so you have one to keep for yourself.
    • Ask Mary Ellyn to order the number you need.  You will need 8GB size thumbdrives.  Do this well in advace of the review.
    • Ask Mary Ellyn to make the labels for the thumbdrives.  An example of the text on the label is "LBNF/DUNE IPR 3/2018" or "LBNF CD3b". Do whatever makes sense.
    • Arrange with OPSS to borrow 3 of their thumbdrive makers before the review to make them.
  • Do the day or two before the review
    • Borrow the thumbdrives from OPSS
    • Create a directory on your computer titled the same as the review
    • Create two subdirectories titled 'Agenda' and 'Documents'
    • Go to the agenda and master document list for the review to download everything to your computer
    • For the agenda items:
      • Create subdirectories under Agenda for the main session and each of the breakout sessions
      • Download all agenda presentations into their appropriate subdirectory.  The names of the presentation files should have the name of the presenter in them so they can be identified easily.
    • For the documentation:
      • Create subdirectories under Documents for each of the document views you created.
      • Download the documents to their appropriate subdirectories
      • Here is general guidance on this process with is tedious -
        • Only download the documents in the main section of each docdb document
        • if there are several (a fuzzy term) documents in the docdb item you should probably create a subdirectory under the view directory and title it the same as the document and put all the files there.
        • if a file does not have a name that will enable reviewers to understand what it is, add text to the filename.  Only do this for the truly obscure filenames like '03r4t6x.pdf'. Usually you can find this text in the description associated with that particular file.
    • To create the thumbdrives:
      • Create the first thumbdrive by copying from the area you made on your computer above to the thumbdrive
      • Insert this first thumbdrive into the thumbdrive maker, and insert 2 blank thumbdrives.  You might want to scan the thumbdrive maker instructions. You should be able to take all the defaults and hit the 'copy' (not sure if that is what it is called, maybe 'duplicate'?) function.
      • Once the copying is done, you can take out the two newly made thumbdrives and use them to do the same in the other two thumbdrive makers.
      • You do not need to remove the thumbdrive that is being copied from in order to make the next set.  Just remove the two newly made thumbdrives and insert two more blank ones.
      • It takes 10-15ish minutes to create the two copies for 4-5 GBs of data.
      • Keep one thumbdrive for yourself
      • Spot check each thumb drive by inserting it into your computer and looking at one or two of the subdirectories to make sure they look correct.
      • I ususally did not return the thumbdrive makers to OPSS till after the review in case i needed to make more.
Web part config for "Fermilab Hiding Group Headers":


Content Editor web part config (the URL under Content link
is a little different from that belowand is included in the
instructions.)

(showing Advanced portion)​